Results 1 to 6 of 6
  1. #1
    Newbie
    Join Date
    Jul 2018
    Location
    WA
    Posts
    24

    Default Broken another valve spring

    Hi guys,

    I have a dart based ford 363 Windsor EFI roller block. I have Jesel shaft rockers. Its in a AU XR8. I seem to be breaking valve springs. It is a race motor. rev it to 7000. First spring I broke was a PAC beehive on #4 exhaust. Got scared of dropping valve so replaced all with duals. A few races later broke #3 exhaust. They are PAC springs. I do drive it on the street.

    I have a vac-u-pan setup that does suck a bit, in fact sucks a bit of oil. The pick up of the RH side VC is down that end of the head, ie number 3 and 4 cylinder. Im thinking would this be sucking oil away from the springs and causing them to break. Also both exhaust, so hotter.

    Any thoughts? Cheers
    Last edited by TKFD; 11-04-2019 at 11:30 PM.

  2. #2
    Do you ever leave? paulzig's Avatar
    Join Date
    Oct 2008
    Location
    Gold Coast
    Posts
    15,786

    Default

    If you have a muffler system with a bit of backpressure to keep it quiet a vac-u-pan setup wont work and will add crank case pressure instead of vacuum.. Less likely to cause spring breakage from less oil top end vs component mismatch so I would check the basics first..

    Do you have the correct retainers for the springs, are they loose or really tight on the spring? The locators on the bottom same with them.

    Also how far from coil bind are the springs set up?

    Did you build yourself or go thru a builder?

  3. #3
    Do you ever leave?
    Join Date
    Jul 2009
    Location
    Childers Qld
    Posts
    4,175

    Default

    after checking the above ,,,,, what valve springs did the cam manufacturer recommend?

  4. #4
    Do you ever leave? EH179's Avatar
    Join Date
    Jan 2008
    Location
    Ipswich. QLD
    Posts
    3,918

    Default

    Could be suffering some funky harmonics in the valve train.

  5. #5
    casual poster kiwiholdenman's Avatar
    Join Date
    May 2007
    Location
    Wellington NZ
    Posts
    250

    Default

    Yeah valve bounce lol ! hey mate you will know if the vac pan setup is working when you see it puffing a bit of oily/blue smoke out the exhaust.
    Mainly on deceleration.
    If not then like Pauly said it wont be working.

  6. #6
    Newbie
    Join Date
    Jul 2018
    Location
    WA
    Posts
    24

    Default

    Hi guys sorry late reply, log-in issues.

    Yes vac-u-pan works well. Pulls about 5Hg. Im going to get rid of it as it sucks too much oil, and have to empty can about 400ml after each race meet.

    It just seems co-incidental that broke both the springs at the same spot under the VC breather, where it sucks from. I assume its been setup right, done by a reputable head guy. I did have the vac-u-pan on the old motor, but that was a 347 stock block with a much smaller cam and only revved it to 6K. So, using a bigger cam with more lift, ramp rate and more revs doesn't help things.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Broken valve spring
    By EVL in forum Holden V8's
    Replies: 43
    Last Post: 21-02-2019, 03:46 AM
  2. Broken valve shields - what to replace?
    By neRok in forum Chevrolet
    Replies: 2
    Last Post: 08-05-2017, 07:52 PM
  3. Valve Spring advice please
    By Deuce. in forum Conversions, Rebuilds & Project Cars
    Replies: 7
    Last Post: 15-02-2015, 09:02 PM
  4. Removing Valve Spring Q's
    By neRok in forum Holden V8's
    Replies: 4
    Last Post: 07-08-2011, 03:18 PM
  5. VT SS 5.0 broken valve lifter retainer plate (conversion)
    By Tommy279 in forum Conversions, Rebuilds & Project Cars
    Replies: 0
    Last Post: 03-07-2011, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •