Results 1 to 9 of 9
  1. #1
    casual poster
    Join Date
    Jul 2015
    Location
    Sunshine Coast
    Posts
    75

    Default VT 5ltr race car wiring

    Hey all

    I'm in the process of stripping my VT 5ltr for sprints and track work. Need a few questions answered in regards to the wiring. Aside from keeping the obvious things like headlights, brakelights, indicators and wipers, I would like to keep some basics like rear window demister.
    1. Does the engine ecu require the bcm to operate or can it be disconnected and just simplify the wiring to existing engine and lighting harnesses?
    2. If the bcm is required, can the wiring for items not required just be removed at the bcm?
    3. What items would need to be left or circuits completed for bcm/ecu to still operate?
    4. Would removing the airbag wiring effect the ecu?

    I hope all that makes sense? I'll probably think of more questions but that should get me started.

    Cheers

  2. #2
    Senior Member grahamjb's Avatar
    Join Date
    Mar 2013
    Location
    Perth
    Posts
    458

    Default

    If you are going to use it for track work you will probably be getting the PCM flashed for improved performance and when you do this, get the VATS removed which will allow the engine to run without the BCM. You can then manually wire in what circuits you want to use.

    Without going into detail there are different BCM's depending on the model and they are used for a number of functions such as heated rear window control, wiper control automatic lights, speed sensitive power steering, A/C, electric windows etc

    Refer to the attached image.
    VT VX VY V2 WH WK BCM types[1].jpg

  3. #3
    casual poster
    Join Date
    Jul 2015
    Location
    Sunshine Coast
    Posts
    75

    Default

    Thanks Graham

    I will talk to my local tuner about getting the pcm flashed and vats removed and then I can go to town I guess

  4. #4
    casual poster
    Join Date
    Jul 2015
    Location
    Sunshine Coast
    Posts
    75

    Default

    No joy with local tuner as he doesn't play with delco stuff anymore, only Ls and aftermarket. Another tuner wants $330 to remove vats! Seems a bit pricey to me. Still have another to call tomoz

  5. #5
    casual poster
    Join Date
    Jul 2015
    Location
    Sunshine Coast
    Posts
    75

    Default

    Ok so I bought a vt 5ltr chip from commodoregear off ebay that has vats removed. I have stripped out all the unnecessary wiring and installed the chip. I have relocated the battery to the boot and wired up the starter and alternator correctly back to the original engine bay fuse box. I have installed an igntion switch and push button stater

    The ignition switch is connected to the pink/black wire which powers the engine control relay and the fuel pump. It also powers the push button starter. The push button starter is connected to the red/white wire to the start relay

    When I turn on the ignition the fuel pump primes for a second then turns off, I push the start button and nothing happens although the wire is pushing 12.5volts to start relay. So I tried removing the start relay and bridged the main wires and the engine started but won't keep running

    I tested spark and there is plenty the and continues to spark as the engine is turned over so that is working fine. I then put a test light across and injector plug and nothing

    So my questions are

    1. Could the chip be faulty or not have vats removed as the engine doesn't continue to run?
    2. It seems like the pcm isn't grounding the start relay (grey wire to pcm feom relay)
    3. Am I missing a wire somewhere to ground the start relay????
    Pics are of the pcm harness plugs showing wires that were discarded and of ignition wire (pink/black) and start wire (red/white)

    Please help

    Sent from my SM-N950F using Tapatalk

  6. #6
    casual poster
    Join Date
    Jul 2015
    Location
    Sunshine Coast
    Posts
    75

    Default

    Replacement memcal arrived today. Fired up first go with push button starter and ran like a treat! Was definitely a vats problem with the first memcal

  7. #7
    Not the Kingswood! hq308's Avatar
    Join Date
    May 2010
    Location
    The Riff
    Posts
    2,225

    Default

    Awesome that's good to hear, I'm sure it would have done your head in trying to work it out.

  8. #8
    casual poster
    Join Date
    Jul 2015
    Location
    Sunshine Coast
    Posts
    75

    Default

    It sure did. So relieved it was the memcal as I was sure I was removing the wiring correctly and if it had of been something I had done I would have been lost

  9. #9
    casual poster
    Join Date
    Jan 2012
    Location
    Melbourne
    Posts
    289

    Default

    Mate i had the same problem with that same seller off ebay. Got my money back in the end. Spent a very long chasing my tail because of it. CEL was always illuminated, and the only way it would run was with pins 5&6 bridged in diagnostic mode!

    I believe it was a VT memcal. As soon as I got the right memcal everything was good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wiring diagram Vt 5ltr
    By turbo1075 in forum Members Lounge
    Replies: 1
    Last Post: 15-09-2016, 06:49 PM
  2. 5ltr wiring diagram
    By 55DART406 in forum Bodywork, Styling, Wiring & Sound
    Replies: 9
    Last Post: 08-02-2014, 07:53 PM
  3. wiring a vr efi 5ltr to a hj panelvan
    By alllan78 in forum Conversions, Rebuilds & Project Cars
    Replies: 5
    Last Post: 31-01-2013, 07:08 PM
  4. vn 5ltr wiring diagrams
    By holdn8 in forum Holden V8's
    Replies: 4
    Last Post: 02-03-2010, 10:07 PM
  5. 5ltr statesman vrs 5ltr wagon
    By DR EVIL in forum Members Lounge
    Replies: 30
    Last Post: 06-04-2009, 07:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •